FoolFuuka/Upgrading

Upgrading foolfuuka

   cd /var/www/foolfuuka/

cd to the FF dir, there are 2. one for desu and 1 for rbt

rbt-foolfuuka is the rbt one. Same thing works in both dirs

   [email protected]:/var/www/foolfuuka $ git remote -v

this shows you where it's pulling from. We are pulling from pleebe's git repo^C

   sudo -u www-data git pull origin

Then restart php7 or hhvm

Switching to PHP 7.2

Update to the latest version of pleebe/foolfuuka and checkout the latest experimental branch.

If you just ran PHP7 on the normal codebase otherwise, there would be a Void error due to the use of old unsupported functions. Fatal error: Cannot use 'Void' as class name as it is reserved in /var/www/foolfuuka/vendor/foolz/plugin/src/Void.php on line 12

   cd /var/www/
   git clone https://github.com/pleebe/foolfuuka # if your directory doesn’t already exist
   git pull origin
   git checkout experimental

Pleebe’s FoolFuuka instance now supports PHP7.2 instead of HHVM. PHP7.2 is not likely to be available from 16.04 LTS repos since those repos are too old, so add the ppa.

   sudo add-apt-repository ppa:ondrej/php
   sudo apt-get update
   sudo apt-get install php7.2-fpm php-bcmath php-curl
   composer install # reinstall all php plugins

Then make sure to edit nginx configs to work for the new PHP7 socket. Check its ini for the socket name, and replace /etc/nginx/rbt.conf with it.

hhvm.conf -> php7-2.conf

You may want to increase the amount of workers in php to the amount of cores available, see php.ini.